Knowledge Base

Article ID: 1006 - Last Modified:

How can I create a custom solvent model for Desmond simulations?

Solvent models are essentially Maestro files that contain equilibrated solvent molecules in a unit cell at the desired density, with certain properties supplied. A suggested procedure for creating a solvent box is given below.

Note: Only pure solvents are supported. Solvents that are mixtures (binary solvents) are not supported.

Note: This is a complex procedure. You should follow the steps exactly. If something goes wrong, start again and make sure you have followed every step.

The first stage is to create a cubic array of solvent molecules in Maestro, which you can do as follows. If you have the Materials Science Suite from 2013-3 or later, you can use the Disordered System Builder panel to create the cubic array. You must choose only one component if you use this panel.

  1. Start Maestro, or in an existing Maestro session, ensure that you have an empty project.
  2. Import the molecule of interest into Maestro, or build it in Maestro and create an entry from it. Ensure that you give the entry a meaningful title.
  3. Open the Project Table and select the entry.
  4. Duplicate the entry to create 16 entries, by typing CTRL+A CTRL+D four times.
  5. Select all entries (CTRL+A) and include them in the Workspace (CTRL+N).
  6. Type tile in the Commands text box (command input area) in the main window. The entries are now placed in a grid in the plane of the Workspace, with new coordinates. (Do not use the Tile toolbar button, as this button does not change the coordinates, only the display.)
  7. In the Project Table panel, choose Entry → Merge. A new entry is created with the molecules from the Workspace. Make sure that it is the only selected entry.
  8. Delete the original set of entries by choosing Select → Invert, then Entry → Delete. There should now be only one entry containing all the molecules.
  9. Include the new entry in the Workspace, and choose View → Align
  10. Select YZ for Align three or more atoms to a plane, then pick the same atom in three of the molecules. You must ensure that the atoms are not in a straight line. Do not pick the same atom in three molecules in the same row. Instead, pick two from the first row and one from the second.
  11. Click Align, then Update Coordinates. The plane of the "sheet" of molecules is rotated and the coordinates are now updated.
  12. Duplicate this entry once with CTRL+A CTRL+D. Only do one duplication, because tiling of two entries places them side-by-side, but tiling of more than two creates a grid.
  13. Repeat steps 5 – 7. You should now have a single entry with two "sheets" of molecules.
  14. Duplicate this entry once with CTRL+A CTRL+D, and repeat steps 5 – 7. You should now have a single entry with four "sheets" of molecules that make up a 4×4×4 box. (If you don't, delete what you have and start over.)

For smaller solvent molecules, you should probably double the size of the box, to produce a box whose sides are around 30 Å long. To do so, follow the procedure above from step 4 with this entry as the original "molecule". In step 4, duplicate the molecule by typing CTRL+A CTRL+D two times to make 4 entries instead of 16, and stop after doing step 13 – do not do step 14.

Now that you have a box of molecules, you can use Desmond to create the solvent model box, as follows:

  1. Create a model system without solvent, ions, or membrane in the System Builder panel. Use a cubic box, use the Buffer method for the box size, and enter a distance of 1.0. If you used the Disordered System Builder, skip this step, as the model system is already created.
  2. Edit the .cms file for the model system and change solute to solvent. There should be only one or two occurrences of this word.
  3. Open the Desmond Molecular Dynamics panel.
  4. In the Model system section, choose Import from file from the option menu, and import the edited .cms file.
  5. Ensure that the Ensemble class is set to NPT.
  6. Ensure that Relax model system before simulation is selected, otherwise the simulation is likely to fail.
  7. Set the simulation time. A time of 200–400 ps is usually sufficient, but you can use the defaults if you want.
  8. Start the simulation. The simulation randomizes the regular array of molecules, and also ensures that the density is correct for the given temperature and pressure.
  9. When the simulation results are incorporated, add a property as follows:

    1. Choose Property → Add.
    2. Name the property "num component".
    3. Ensure that the type is Integer.
    4. Enter "1" in the Initial value text box.
    5. Click Add.
    The internal name of this property must be edited to change the "family".
  10. From Suite 2013-1 on you can edit the internal name in Maestro, as follows:

    1. Choose Property → Columns → Edit Name/Type.
    2. Select the property "num component".
    3. Select Edit internal data.
    4. From the Family option menu, choose other, and enter "ffio" in the text box.
    5. Click Save Changes.
    If you do the above, you can skip step 12.
  11. Export the resulting solvent entry to a Maestro file. The required properties were automatically added in the Desmond simulation, except for the one that you added manually.
  12. If you did not already change the internal name in step 10, edit the Maestro file, and change "i_user_num_component" to "i_ffio_num_component".

You can now use this Maestro file as a custom solvent file.

Back to Search Results

Was this information helpful?

What can we do to improve this information?


To ask a question or get help, please submit a support ticket or email us at help@schrodinger.com.
Knowledge Base Search

Type the words or phrases on which you would like to search, or click here to view a list of all
Knowledge Base articles