Knowledge Base

Article ID: 1008 - Last Modified:

How can I calculate a relative free-energy difference from Desmond mutation by FEP calculations that were run with two different environments?

Desmond's relative binding or solvation free energies from ligand functional group mutation or ring atom mutation estimate ΔG values for a single environment (e.g. the complex or the bulk solution). These values are recorded in the output structure files and are imported into Maestro.

To calculate differences of these values in Maestro, you can use the Project Table calculator (Table → Calculate) to create a new property that contains the required difference.

From the command line, you can use the script calculate_ddg.py to take the difference between the values in two different environments to provide a ΔΔG value. The syntax is:

$SCHRODINGER/run -FROM desmond calculate_ddg.py jobname1-out.mae jobname2-out.mae [output_file.mae]

where jobname1-out.mae and jobname2-out.mae are the output structure files from the two FEP calculations. These files are in Maestro format, and the ΔG are recorded as an entry property s_des_dG_jobname for each mutant (shown as dG jobname in the Project Table). The output file output-file.mae is optional; the default name is ddG.mae. This file is in Maestro format and contains the ΔG value from both input files. The final ΔΔG result is recorded for each mutant as an entry property s_des_ddG_jobname1-jobname2, which is displayed in the Project Table as ddG jobname1-jobname2. The atom coordinates in the output file are copied from the first input structure file.

Keywords: Desmond, delta delta G

Back to Search Results

Was this information helpful?

What can we do to improve this information?


To ask a question or get help, please submit a support ticket or email us at help@schrodinger.com.
Knowledge Base Search

Type the words or phrases on which you would like to search, or click here to view a list of all
Knowledge Base articles