Knowledge Base

Article ID: 1451 - Last Modified: August 22, 2013

I can't start KNIME on Ubuntu 10.04.1. It tells me that my version of SQLite is too old. Is there anything I can do to get it working?

On Ubuntu 10.04.1 the version of KNIME included in the Schrödinger software installation fails to start, with the error:

"The application has been updated, but your version of SQLite is too old and the application cannot run."

The workaround is to move libsqlite3.so.0 to the disabled_lib folder, so that the system SQLite library is used instead.

cd $SCHRODINGER/mmshare-vversion
mv lib/platform/libsqlite3.so.0 disabled_lib/platform

From Suite 2012 on, this library must also be moved in the Maestro installation:

cd $SCHRODINGER/maestro-vversion
mv lib/platform/libsqlite3.so.0 disabled_lib/platform

Back to Search Results

Was this information helpful?

What can we do to improve this information?


To ask a question or get help, please submit a support ticket or email us at help@schrodinger.com.
Knowledge Base Search

Type the words or phrases on which you would like to search, or click here to view a list of all
Knowledge Base articles