Knowledge Base

Article ID: 1457 - Last Modified:

How can I optimize the performance of Maestro?

If Maestro is unresponsive or slow the first things you should do are:

  • Check that your graphics card is adequate and that your graphics driver is up-to-date.
  • Run and display Maestro locally if at all possible. Displaying Maestro remotely will affect the responsiveness. Running Maestro from a networked disk can result in slow startup.
  • Use your local disk for projects whenever possible. Setting the environment variable SCHRODINGER_TEMP_PROJECT to a local drive will speed up access to scratch projects. Saving projects locally while working on them, then copying them to a networked disk will also improve responsiveness.
  • Check how much memory your machine is using, and whether it is swapping or paging. If it is, close applications that use a lot of memory.

If this does not help, or if you can't take the suggested actions, there are a number of preferences available that can help Maestro reduce its workload, simplify the graphics operations, and yield a more responsive experience.

In Suite 2011 and Suite 2012, you can adjust preferences in the Preferences panel to eliminate operations that could affect performance:

  • Workspace → Graphics: turn off "Full scene anti-aliasing"
  • Feedback → Atom: turn off "Show atom feedback in Status Bar"
  • Feedback → Job: turn off "Show job status feedback in Workspace"
  • Jobs → Monitoring: turn off "Show job status in Workspace status bar"
  • Jobs → Monitoring: Set "Update Monitor panel every" to a larger value.
  • Jobs → Incorporation: set "Incorporate completed jobs" to "Only when monitored"
  • Project → Project Table: turn off "Show 2D image in Row column tooltip"

You should also turn off "Enhanced depth view" on the View menu.

In the Monitor panel, set the Monitor frequency to a larger number, like 30 seconds. (You will have to do this every time you start Maestro in Suite 2011.)

Back to Search Results

Was this information helpful?

What can we do to improve this information?


To ask a question or get help, please submit a support ticket or email us at help@schrodinger.com.
Knowledge Base Search

Type the words or phrases on which you would like to search, or click here to view a list of all
Knowledge Base articles