Supported Platforms

Please choose the version you'd like to view platform support for:

Select OS:

Please note: 

The 2021-4 release will be the last to support CentOS 8. We plan to support an alternative RHEL 8 clone, but have not yet determined which one.

All applications are 64-bit versions only. All supported distributions have a glibc of 2.12 or greater.

Supported

  • RedHat Enterprise Linux (RHEL) 7.8-7.9, 8.1, 8.2, 8.4
    • For RHEL Server you must install some X11 libraries (sudo yum install fontconfig libX11).
  • Rocky Linux 8.4
    • For Rocky Linux you must install some X11 libraries (sudo yum install fontconfig libX11).
  • CentOS 7.8-7.9, 8.1, 8.2, 8.4
    • For CentOS Server you must install some X11 libraries (sudo yum install fontconfig libX11).
    • For CentOS 8 you must install libnsl.
  • Ubuntu 18.04 LTS, and 20.04 LTS
    • For Ubuntu Server, user must also install some X11 libraries (sudo apt-get install fontconfig).
  • SUSE: SLES/SLED 15 SP2 and SP3, SLES/SLED 12 SP5

3D Support

  • Supported: Quad-buffered OpenGL hardware stereo via NVIDIA 3D Vision, Interlaced stereo via Zalman 3D Monitors
  • See http://www.schrodinger.com/kb/1745 for more complete information

 Graphics Cards to Run Maestro

  • Graphics card must support OpenGL 2.1 or greater
  • We strongly recommend running Maestro using a discrete graphics card for optimal performance, though some integrated graphics cards show acceptable performance
    • Our software has been tested most robustly against multiple generations of NVidia graphics cards

Please note: Most graphics issues encountered are addressed by updating the graphics card driver. Please follow your hardware maker or OS distribution instructions to update the graphics driver

Please note: 

Only 64-bit platforms are supported.
Processes that require a GPU are only supported on Linux. This includes but is not limited to Desmond, FEP+, Deep AutoQSAR, Watermap, and GPU Shape.
Jaguar cannot be run in parallel under Windows.

Supported

  • Windows 10, versions 1909, 2004, 20H2, 21H1.

Please note: The multi-session version of Windows 10 Enterprise is not supported

We support English plus internationalized versions of the OS in Spanish, French, German, and Japanese.

3D Support

  • Supported: Quad-buffered OpenGL hardware stereo via NVIDIA 3D Vision, Interlaced stereo via Zalman 3D Monitors
  • See http://www.schrodinger.com/kb/1745 for more complete information

 Graphics Cards to Run Maestro

  • Graphics card must support OpenGL 2.1 or greater
  • We strongly recommend running Maestro using a discrete graphics card for optimal performance, though some integrated graphics cards show acceptable performance
    • Our software has been tested most robustly against multiple generations of NVidia graphics cards

Please note: Most graphics issues encountered are addressed by updating the graphics card driver. Please follow your hardware maker or OS distribution instructions to update the graphics driver

Please note: 

Processes that require a GPU are only supported on Linux. This includes but is not limited to Desmond, FEP+, Deep AutoQSAR, Watermap, and GPU Shape.
Jaguar cannot be run in parallel under MacOS.

Supported

  • macOS 10.14 - 10.15, 11

Unsupported

  • Computers running ARM64-based processors such as the Apple M1 chip
  • Important notice: Once a mac is upgraded to Big Sur, versions of the Schrödinger suite prior to 2021-1 will not be able to be run

3D Support

  • Supported: Interlaced stereo via Zalman 3D Monitors
  • Unsupported: Non-interlaced stereo with dedicated hardware (such as NVIDIA 3D Vision)

 Graphics Cards to Run Maestro

  • Graphics card must support OpenGL 2.1 or greater
  • We strongly recommend running Maestro using a discrete graphics card for optimal performance, though some integrated graphics cards show acceptable performance
    • Our software has been tested most robustly against multiple generations of NVidia graphics cards

Please note: Most graphics issues encountered are addressed by updating the graphics card driver. Please follow your hardware maker or OS distribution instructions to update the graphics driver

Desmond, Watermap, FEP+, Deep AutoQSAR, and GPU Shape

  • We support the following NVIDIA Server/HPC solutions:
    • Kepler architecture - Tesla K80
    • Maxwell architecture - Tesla M40, Tesla M60
    • Pascal architecture - Tesla P40, Tesla P100
    • Volta architecture - Tesla V100
    • Turing architecture - Tesla T4
    • Ampere Architecture - Tesla A100

    •  
  • We support the following NVIDIA Workstation solutions:
    • Pascal architecture - Quadro P5000
    • Turing architecture - Quadro RTX 5000
    • Ampere architecture - RTX A4000, RTX A5000
  • We support only the Nvidia 'recommended/certified' Linux drivers for these cards with minimum CUDA version 11.2
  • Pre-configured Schrödinger compatible GPU boxes for MD and FEP+ are available from Exxact (US).
  • Standard support does not cover consumer-level GPU cards such as GeForce GTX cards.*
  • Support for the Tesla K20,Tesla K40 and Tesla K80 cards is deprecated. While we still expect our GPGPU codes to run, NVIDIA has deprecated support for these cards in the CUDA 11.2 toolkit.

*If you already have another NVIDIA GPGPU and would like to know if we have experience with it, please contact our support at help@schrodinger.com.

To view a list of upcoming infrastructure projects that may require changes from your IT team click here.

Back To Top